Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 16, 2025 - 00:00 UTC
Scheduled
London Maintenance
Migration of the London Data Center network gateways to new switch cores to increase capacity, improve routing performance, and enhance overall stability and scalability of the network infrastructure.
Maintenance Window Start Date: December 16th Start Time: 00:01 UTC End Time: 06:01 UTC Estimated Duration: 6 hours
Expected Impact During the change window, the following impacts may occur: Increased latency due to traffic transitions. Brief service interruptions caused by gateway switchover and routing convergence. Maximum expected total outage: up to 1 hour.
Contact For questions or incidents related to this maintenance, please contact the Network Operations team: netops@latitude.sh (edited)
Posted Dec 03, 2025 - 13:20 UTC
This scheduled maintenance affected: Services (Looking Glass, Remote access) and Regions (LON).