Increased error rate for deployments in North America
Incident Report for Latitude.sh
Update
Fixes have been successfully applied across all regions. Our team is now conducting a detailed review of the incident and addressing each case individually to ensure there is no further impact.
Posted Oct 14, 2024 - 17:54 UTC
Update
Ashburn is now stable. Fixes are being implemented for the remaining locations. We appreciate your patience.
Posted Oct 13, 2024 - 19:04 UTC
Identified
A fix is being implemented on a per-region basis. Error rates have decreased considerably. If you have issues, reach out to us.
Posted Oct 13, 2024 - 15:51 UTC
Update
We are continuing to investigate this issue.
Posted Oct 12, 2024 - 22:29 UTC
Update
We are rolling out fixes across locations. Chicago is now stable.
Posted Oct 12, 2024 - 20:22 UTC
Investigating
We are investigating an increased error rate affecting non-instant deployments in North America. Non-instant deployments are made with an Operating System other than Ubuntu 24.04.

This issue only affects new deployments and reinstallations of existing servers. During the incident, please refrain from reinstalling servers located in the US, and prefer deploying Ubuntu 24.04 over other Operating Systems, if possible.

We are working to address this issue as soon as possible and will provide updates as we learn more and implement the necessary fixes.
Posted Oct 12, 2024 - 20:06 UTC
This incident affects: Regions (MIA (Miami), CHI (Chicago), LAX (Los Angeles), NYC (New York), DAL2 (Dallas), ASH (Ashburn)).