We performed a rollback of the maintenance activity to ensure network and traffic stability. During the validation steps, we encountered an issue that prevented us from proceeding. The maintenance will be rescheduled.
Posted May 15, 2025 - 01:24 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 14, 2025 - 23:00 UTC
Scheduled
Dear Customers, We will update the logical configuration of our core layer infrastructure to optimize our network structure in the London 2 Data Center.
Maintenance Schedule:
- Start Date: May 14th - Start Time: 11:00 PM UTC - End Time: 5:00 AM UTC - Duration: 06 hours
Expected Impact: During this maintenance window, you may experience:
- Increased latency: You may notice delays in network response. - Service disruptions: Short spikes, drops, and interruptions due to traffic switchover. - Total Maximum outage: 01 hour
We understand that network disruptions can be inconvenient, and we apologize for any inconvenience this may cause.
Contact Information: Our dedicated Network Operations Team is available to address any questions or concerns you may have regarding this maintenance. Please reach out to us via email at ([netops@latitude.sh](mailto:netops@latitude.sh))
Posted Apr 30, 2025 - 16:14 UTC
This scheduled maintenance affected: Services (Looking Glass, Remote access) and Regions (LON2).