Incident with Support Center

Incident Report for Latitude.sh

Resolved

This incident has been resolved.
Posted May 31, 2025 - 01:01 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 30, 2025 - 16:49 UTC

Identified

Creating and seeing support tickets is currently unavailable. We are working to reestablish the service.
Posted May 30, 2025 - 16:48 UTC
This incident affected: Services (Dashboard).