Power Issue - LON2

Incident Report for Latitude sh

Resolved

This incident has been resolved. Our team will keep the communication for the affected customers via ongoing tickets.
Posted Aug 08, 2026 - 23:54 UTC

Update

Several servers have been recovered but the full extension of the site is still being worked on at the moment. Our team is still working with the DCO for the full resolution.
Posted Aug 08, 2026 - 11:06 UTC

Identified

Some devices are being recovered. Our team are still working with the DCO to fully recover the site.
Posted Aug 08, 2026 - 03:05 UTC

Update

We are continuing to investigate this issue.
Posted Aug 08, 2026 - 00:29 UTC

Investigating

We are currently investigating this issue.
Posted Aug 08, 2026 - 00:17 UTC
This incident affected: Regions (LON, LON2).