Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 26, 2025 - 16:00 UTC
Scheduled
Dear Customers,
To optimize and improve the reliability of our network infrastructure in the Singapore Data Center, we will be conducting a maintenance as follows:
Maintenance Schedule: - Start Date: March 26th - Start Time: 4:00 PM UTC - End Time: 7:30 PM UTC - Duration: 3 hours and 30 minutes
Expected Impact: - Service disruptions: short spikes, drops, interruptions, or latency increase due to traffic switchover. - Maximum outage: Up to 30 minutes of cumulative downtime.
Contact Information: Our dedicated Network Operations Team is available to address any questions or concerns you may have regarding this maintenance. Please reach out to us via email at netops@latitude.sh.
We appreciate your understanding and support as we work to improve our network infrastructure.
Posted Mar 24, 2025 - 20:13 UTC
This scheduled maintenance affected: Regions (SGP).