Network Outage at MEX
Incident Report for Latitude.sh
Resolved
This incident has been resolved.
Posted Mar 08, 2024 - 14:46 UTC
Investigating
Our Network Engineering team is investigating a network outage at our Mexico data center.
If you need more information, please get in touch with us at netops@latitude.sh.
Posted Mar 08, 2024 - 11:36 UTC
This incident affected: Regions (MEX (Mexico)).