LAX2 Outage

Incident Report for Latitude.sh

Resolved

This incident has been resolved. A follow up RCA will be sent to the affected customers.
Posted Jun 28, 2025 - 20:00 UTC

Investigating

We are currently investigating a major outage affecting all devices in our LAX2 region. Our teams are actively working to identify the root cause and restore services as quickly as possible.

We will provide further updates as soon as we have more information.

Thank you for your patience.
Posted Jun 28, 2025 - 14:33 UTC
This incident affected: Regions (LAX2).