Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 17, 2025 - 23:00 UTC
Scheduled
Dear Customers, In order to optimize our network structure in the Frankfurt Data Center, we will update the logical configuration of our Core Layer Infrastructure.
Maintenance Schedule:
- Start Date: March 17th - Start Time: 11:00 PM UTC - End Time: 5:00 AM UTC - Duration: 06 hours
Expected Impact: During this maintenance window, you may experience:
- Increased latency: You may notice delays in network response. - Service disruptions: Short spikes, drops, and interruptions due to traffic switchover.
We understand that network disruptions can be inconvenient, and we apologize for any inconvenience this may cause.
Contact Information: Our dedicated Network Operations Team is available to address any questions or concerns you may have regarding this maintenance. Please reach out to us via email at (netops@latitude.sh)
Posted Mar 05, 2025 - 14:27 UTC
This scheduled maintenance affected: Services (Looking Glass, Remote access) and Regions (FRA).