Increased errors on the Dashboard/API

Incident Report for Latitude.sh

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 19:02 UTC

Investigating

We are investigating an increased error rate affecting multiple actions in our systems. Your server is not impacted.

We are working to address this issue as soon as possible and will provide updates as we learn more and implement the necessary fixes.
Posted Nov 18, 2025 - 11:50 UTC
This incident affected: Services (Dashboard, API).