Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 03, 2026 - 01:00 UTC
Scheduled
Hi Customer,
Emergency maintenance will take place at our Amsterdam Data Center.
Purpose of Maintenance:
During routine operational activities, we identified an issue affecting the switch redundancy protocol on one of our core switching devices. To maintain network stability and ensure the continued reliability of the platform, an emergency maintenance window has been scheduled to perform corrective actions and reboot the affected device.
As part of this procedure, traffic will be temporarily migrated to the redundant core infrastructure while the device is restarted and validated. Continuous monitoring and validation will be performed throughout the maintenance window to ensure network stability.
Impacted Service(s):
No downtime is expected during this maintenance. However, as traffic is switched between redundant network paths, customers may experience brief session reconnections, routing convergence events, or temporary latency variations during traffic failover and restoration.
Start Date and Time: Wed, 03 Jun 2026 01:00:00 AM UTC
End Date and Time: Wed, 03 Jun 2026 05:00:00 AM UTC
Do you have questions about this maintenance activity? Did you know you can chat with us 24/7/365? Most support interactions are handled best via email at [netops@latitude.sh](mailto:netops@latitude.sh).
Posted Jun 02, 2026 - 16:21 UTC
This scheduled maintenance affected: Services (Looking Glass, Remote access) and Regions (AMS).