The network protection procedure is now complete. The core layer is stable, and no further oscillations are expected. Thank you for your patience.
Posted Apr 11, 2026 - 03:41 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 11, 2026 - 01:00 UTC
Scheduled
As part of our commitment to infrastructure resilience and proactive service safeguarding, we will be performing a Recovery Network Protection procedure in our FRA facility. This scheduled action is designed to ensure the continued integrity of our core layer and prevent any potential long-term service degradation.
Maintenance Schedule:
Start Date: April 11, 2026 Start Time: 01:00 Am UTC End Date: April 11, 2026 End Time: 04:00 am UTC
Duration: 3 Hours
Impact: We do not anticipate a complete service outage during this procedure. However, as traffic is rerouted to redundant paths, clients may experience brief service oscillations or momentary packet loss for a period of up to 30 minutes while the network converges.
Contact Information: If you have any questions or concerns, please feel free to reach out to our Network Operations Team at netops@latitude.sh.
We appreciate your immediate understanding as we work to resolve this critical issue and ensure the continued reliability of our infrastructure.
Posted Apr 09, 2026 - 21:17 UTC
This scheduled maintenance affected: Regions (FRA).