Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 19, 2026 - 08:00 UTC
Scheduled
Dear Customers, We have identified the need to adjust Layer 2 and Layer 3 load-balancing parameters in Bogotá Core Layer as part of our continuous service improvement efforts.
Maintenance Window - Start Date: February 19th - Start Time: 08:00 AM UTC - End Time: 11:00 AM UTC - Estimated Duration: 03 hours
Expected Impact During the maintenance window, the following impacts may occur:
- Temporary communication flaps or packet drops due to adjustments and synchronization. - Maximum expected total outage: up to 10 minutes.
Contact Information For questions or incidents related to this maintenance, please contact the Network Operations team: netops@latitude.sh
Posted Feb 12, 2026 - 15:42 UTC
This scheduled maintenance affected: Services (Looking Glass, Remote access) and Regions (BGT).