Power Failure - Buenos Aires

Incident Report for Latitude.sh

Resolved

This incident has been resolved.
Posted Sep 29, 2025 - 00:22 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 28, 2025 - 23:28 UTC

Identified

We are currently experiencing a large-scale service impact in Buenos Aires. The power provider for the colo company is performing work at the local substation; our infrastructure team is fully engaged and working to restore normal operations.

We do not have an ETA yet. We will keep you updated via this status page and through your any support channel you request contact.
Posted Sep 28, 2025 - 15:57 UTC
This incident affected: Regions (BUE).