Deploy and Reinstall at Buenos Aires

Incident Report for Latitude.sh

Resolved

The maintenance has ended; deploy and reinstall are operational at our Buenos Aires (Argentina) site.
Posted Nov 19, 2025 - 07:52 UTC

Identified

As part of emergency maintenance, deploy and reinstall operations at our Buenos Aires (Argentina) site are currently unavailable.
Posted Nov 19, 2025 - 07:07 UTC
This incident affected: Services (Automation Tool) and Regions (BUE).