Incident with Dashboard and API
Incident Report for Latitude.sh
Resolved
This incident has been resolved.
Posted Mar 23, 2023 - 14:13 UTC
Investigating
We've identified a problem with Dashboard and API. Our engineering team is focused on investigating and solving the issue as soon as possible. We will update this status with more details soon.
Posted Mar 23, 2023 - 13:51 UTC
This incident affected: Services (Dashboard, API).