Network Outage
Incident Report for Latitude.sh
Resolved
We will update this status with a post-mortem as soon as all the information has been reviewed.
Posted Sep 12, 2024 - 16:29 UTC
Update
The issue has been resolved, and our teams are working to determine the root cause. We will update this status with more information soon.
Posted Sep 11, 2024 - 18:07 UTC
Investigating
We are currently investigating an ongoing connectivity outage affecting the London, Dallas, New York, and Chicago regions. We will provide updates as we work to identify the root cause.
Posted Sep 11, 2024 - 17:51 UTC
This incident affected: Regions (CHI (Chicago), NYC (New York), DAL2 (Dallas), MEX (Mexico)).